tried submodules and corrupted repo

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

tried submodules and corrupted repo

Thomas Koch
Hi,

in my trial to use a submodule, it seems that I messed up my repo.

I've put both repos at
http://git.koch.ro
clone url is
http://git.koch.ro/git/REPONAME

I wanted to have the git-php-wrapper repo as a submodule inside wigit,
which did not work at all. I always ended up with a git-php-wrapper
subdir and a .git inside it, but no workdir files.

Now I wanted to start from scratch, to clone wigit again to my local
machine. But when I try
git clone http://git.koch.ro/git/wigit
it says:
Initialized empty Git repository in /var/checkouts/wigit/.git/
warning: remote HEAD refers to nonexistent ref, unable to checkout.

Is there a way to resque my wigit repo? And how to get the submodule
working afterwards?

Best regards,
--
Thomas Koch, Software Developer
http://www.koch.ro

Young Media Concepts GmbH
Sonnenstr. 4
CH-8280 Kreuzlingen
Switzerland

Tel    +41 (0)71 / 508 24 86
Fax    +41 (0)71 / 560 53 89
Mobile +49 (0)170 / 753 89 16
Web    www.ymc.ch

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [hidden email]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Reply | Threaded
Open this post in threaded view
|

Re: tried submodules and corrupted repo

Thomas Koch
Am Dienstag 12 August 2008 10:09:38 schrieben Sie:

> Hi,
>
> in my trial to use a submodule, it seems that I messed up my repo.
>
> I've put both repos at
> http://git.koch.ro
> clone url is
> http://git.koch.ro/git/REPONAME
>
> I wanted to have the git-php-wrapper repo as a submodule inside wigit,
> which did not work at all. I always ended up with a git-php-wrapper
> subdir and a .git inside it, but no workdir files.
>
> Now I wanted to start from scratch, to clone wigit again to my local
> machine. But when I try
> git clone http://git.koch.ro/git/wigit
> it says:
> Initialized empty Git repository in /var/checkouts/wigit/.git/
> warning: remote HEAD refers to nonexistent ref, unable to checkout.
>
> Is there a way to resque my wigit repo? And how to get the submodule
> working afterwards?
>
> Best regards,

It seems that all my problems araised, because I did not set up my GIT
repo server properly. I forgot to make post-commit executable which runs
git-update-server-info.

Sorry for the noise.
--
Thomas Koch, Software Developer
http://www.koch.ro

Young Media Concepts GmbH
Sonnenstr. 4
CH-8280 Kreuzlingen
Switzerland

Tel    +41 (0)71 / 508 24 86
Fax    +41 (0)71 / 560 53 89
Mobile +49 (0)170 / 753 89 16
Web    www.ymc.ch
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [hidden email]
More majordomo info at  http://vger.kernel.org/majordomo-info.html