Help fix gpg failed to sign the data

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Help fix gpg failed to sign the data

Mottie
This post has NOT been accepted by the mailing list yet.
This post was updated on .
Since I've updated to Git v2.10.0, I have been unable to sign my commits.

I discussed my issue with _ikke_ (http://colabti.org/irclogger/irclogger_log/git?date=2016-09-13#l1660) and was directed to ask here. This is a summary of the discussion:

_ikke_ Mottie: What happens if you try?
Mottie _ikke_: I see "error: gpg failed to sign the data" "fatal: failed to write commit object"

_ikke_ Mottie: What happens if you try to manually sign a file? gpg -b {file}
Mottie _ikke_: hmm, that seems to work

_ikke_ Mottie: Ok, now GIT_TRACE=1 git commit ...
Mottie _ikke_ that worked too

_ikke_ Oh, you don't have signing enabled by default?
Mottie when I use git commit -S.. that's when it failes
_ikke_ right
Mottie I turned it off because I couldn't commit anything
_ikke_ makes sense

_ikke_ GIT_TRACE=1 git commit -S
Mottie 11:19:15.553600 run-command.c:336 trace: run_command: 'gpg' '--status-fd=2' '-bsau' '#######' error: gpg failed to sign the data fatal: failed to write commit object

_ikke_ Mottie: Ok, can you try that command then? gpg -bsau '#######' {file}
Mottie _ikke_ works perfect

_ikke_ Mottie: Ok, and now try to add --status-fd=2
Mottie _ikke_ ok that worked

_ikke_ hmm
_ikke_ Then I'm at a loss. The !mailing_list can help you better.

I have uninstalled, then reinstalled Git v2.10.0 64bit for Windows 10, but I did not erase my settings. Any help on how to proceed would be greatly appreciated.

Rob